Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 08, 2024 - 09:00 EST
Scheduled
On Sunday, December 8, 2024, the Coverity on Polaris SaaS production systems will be upgraded to version 2024.9.1 during a scheduled maintenance window of 9am to 3pm Eastern Time.
What’s new? - Support for Coverity version 2024.9.1 with a critical bug fix which was resulting in long scan times for certain customers - Branding updates to the platform including UI changes, reporting/email template updates, and availability of the Black Duck domain - Access to equivalent Black Duck URLs (existing Synopsys URLs will continue to work) - Both the Synopsys and the Black Duck domains will be accessible - Customers with SAML SSO enabled will need to carefully read documentation instructions on steps needed to access their equivalent Black Duck domain - Access to new Black Duck Azure extension and Jenkins plugin - Black Duck Coverity on Polaris Jenkins plugin version 2.0.0; the Synopsys Coverity on Polaris Jenkins plugin is deprecated and will not be maintained going forward - Black Duck Coverity on Polaris Azure extension version 2.0.0; the Synopsys Coverity on Polaris Azure extension is deprecated and will not be maintained going forward - IMPORTANT NOTE: Customers must migrate to the Black Duck Azure extension and Jenkins plugin versions 2.0.0 as soon as possible and prior to the next Coverity on Polaris 2024.12.0 release (January 2025) - Actions needed before upgrading Jenkins: - Before moving to the new Black Duck® Jenkins 2.0.0 plugin, customers should record and save their existing system configuration - It is recommended to review documentation before upgrading as there are changes that need to be made to ensure continued successful execution within pipelines - Actions needed before upgrading Azure: - Before moving to the Black Duck® Azure extension, customers must manually uninstall the Synopsys extension. - Installing the Black Duck® extension will ensure customers receive future updates.
Important Notes Regarding the Coverity on Polaris Migration to Black Duck - After the Coverity on Polaris 2024.9.1 release, users will be able to login to their existing Polaris URL with existing credentials as usual - Aside from the UI and branding changes noted above, no other impact will occur to customer workflows immediately - Org Admins will be able to upgrade their Coverity on Polaris URL at a time convenient to their organization following the instructions provided in the documentation including taking the necessary steps with SAML configuration - Azure extensions and Jenkins plugins should be upgraded as soon as possible and prior to the Coverity on Polaris 2024.12.0 release (January 2025) - In preparation for the upcoming change, please update allow lists to add the following URLs and IP addresses: - https://tools.cop.blackduck.com (IP address 34.49.24.155) - https://storage-us.cop.blackduck.com (IP address 130.211.21.249) - https://storage-eu.cop.blackduck.com (IP address 34.36.253.210) - https://.cop.blackduck.com (no change to IP address) - Additional URL changes of note include: - https://community.synopsys.com/s/ is now https://community.blackduck.com/. - Please see Black Duck Domain Change FAQ for more information including updates as they occur
Deprecations: - Coverity 2023.12.1 - Kotlin 1.9 - Open/Oracle JDK 22 - .NET 6 - macOS 12 - Go 1.21 - LLVM Clang 9.0 - fs_capture_build_options (Note: No action is required as arguments will automatically be translated to a comparable capture mechanism) - Synopsys Coverity on Polaris Azure DevOps extension v 1.3.1 or older - Synopsys Coverity on Polaris Jenkins plugin v 1.4.0 or older
End of Support - None
Posted Dec 03, 2024 - 17:46 EST
This scheduled maintenance affected: Integration Services, Reporting Services, Rest Services, SCAN Services, UI Services, and BLA.