Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 19, 2025 - 09:01 EST
Scheduled
On Sunday, January 19, 2025, the Coverity on Polaris SaaS production systems will be upgraded to version 2024.12.0 during a scheduled maintenance window of 9am to 3pm Eastern Time.
What’s new? Support for Coverity version 2024.12.0 with the following updates: - macOS 15 - Go 1.23 - Java 23 - Xcode 16.0 - Open/Oracle JDK 23 - Upgraded version of Detekt to 1.23.6 (Kotlin) Checker updates as part of Coverity 2024.12.0
Black Duck Migration Updates Customers are recommended to migrate their Coverity on Polaris instance to the Black Domain by February 14, 2025. - Migration instructions can be found here. - Customers must migrate to the Black Duck Azure extension and Jenkins plugin versions 2.0.0 prior to the Coverity on Polaris 2024.12.0 release. Please see Black Duck Domain Change FAQ for more information including updates as they occur.
Deprecations: - Coverity 2024.3.1 - Coverity 2024.3.0 - Go 1.22 - JSHint - Synopsys Coverity on Polaris Azure DevOps extension v 1.3.1 or older - Synopsys Coverity on Polaris Jenkins plugin v 1.4.0 or older
End of Support - Coverity 2023.12.1 - Open/Oracle JDK 22 - .NET 6 - macOS 12 - Go 1.21 - Java 22 - fs_capture_build_options and cov-capture (Note: No action is required as arguments will automatically be translated to a comparable capture mechanism)
Posted Jan 14, 2025 - 12:26 EST
This scheduled maintenance affected: Integration Services, Reporting Services, Rest Services, SCAN Services, UI Services, and BLA.