Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2025 - 15:02 EDT
Scheduled
On Sunday, June 1, 2025, the Coverity on Polaris SaaS production systems will be upgraded to version 2025.3.0 during a scheduled maintenance window of 9am to 3pm Eastern Time.
What’s new? - Support for Coverity version 2025.3.0 with the following updates: - .NET 9.0 - Kotlin 2.1.0 - GNU GCC 14.1 - Checker updates as part of Coverity 2025.3.0 include the following important note: - IMPORTANT NOTE: The Python API checker updates impact merge keys and will result in dismissed issues reappearing as new issues and old issues being closed and no retention of triage history.
Black Duck Migration Updates - Customers are recommended to migrate their Coverity on Polaris instance to the Black Domain. The deadline has been updated to September 1, 2025. Migration instructions can be found at here. - Please see Black Duck Domain Change FAQ for more information including updates as they occur.
Deprecations - Support for the following is deprecated and will be removed in a future release: - Coverity 2024.6.0 - Coverity 2024.3.0 - Go 1.22 - Kotlin 2.0.x - Oracle JDK 23 - Open JDK 23 - Synopsys Coverity on Polaris Azure DevOps extension v 1.3.1 or older - Synopsys Coverity on Polaris Jenkins plugin v 1.4.0 or older
EOL - Support for the following will be removed with this release: - Coverity 2024.3.1 - Coverity 2024.3.0 - JSHint - Kotlin 1.9
Extending for two hours
Posted Jun 01, 2025 - 14:30 EDT
This scheduled maintenance affected: Integration Services, Reporting Services, Rest Services, SCAN Services, UI Services, BLA, and UI Services.