Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2024 - 08:01 EDT
Scheduled
On Sunday, July 21, 2024, the Coverity on Polaris SaaS production systems will be upgraded to version 2024.6.0 during a scheduled maintenance window of 8am to 2pm Eastern Time.
What's new? Support for Coverity version 2024.6.0 with the following updates: * Go 1.22 * Java 22 * LLVM Clang 18.1.0 and Xcode 15.3 * Open / Oracle JDK 22 * PHP model improvements (Note: these updates could result in an increased number of defects found) * New or updated checkers for C#, Java, JavaScript/TypeScript, and Visual Basic * New secret patterns and checks for JavaScript and Java
Support for new taxonomies in application reports * 2023 CWE Top 25 * 2023 CWE On the Cusp
Deprecations: Support for the following is deprecated and will be removed in a future release: * Coverity 2023.9.2 * macOS 12 * Go 1.21 * LLVM Clang 9.0 * fs_capture_build_options (Note: No action is required as arguments will automatically be translated to a comparable capture mechanism)
Removal of support: Support for the following will be removed with this release: * Coverity 2023.12.2 * Coverity 2023.6.0 * Coverity 2022.9.2 * .NET 7.0 * Go 1.20 * Java 11 * LLVM Clang 8.x * Oracle/Open JDK 11
Posted Jul 16, 2024 - 11:59 EDT
This scheduled maintenance affected: Integration Services, Reporting Services, Rest Services, SCAN Services, UI Services, and BLA.